Focal distance set using material library - incorrect distance

Hi I have a gweike cloud RF laser.
I’m new to LightBurn.

I’m trying to setup my material library.
I’ve set the material thickness property’s as such:
image

I also have light burn configured to control the Z axis.

When I start the cut. The Z axis moves to the material thickness property I have set in the library.
But I would like to add an offset to the this. Or maybe I have something miss configured in my machine.
If I set the material thickness to 6.35mm, I would expect the z axis to move to the z position 10.35mm.
But currently, the Z axis is always moving to what ever the material thickness is set to in the material library in this case 6.35mm.
image

The machine settings are configured like this:

I tried to adjust the Focus distance parameter, that doesn’t seem to make a difference in this behavior.

You’re the third Gweike user in the last couple of weeks facing issues with Z-axis/focusing.

I almost wonder if Gweike deserves its own section.

In any case, would be good if you can put your heads together on this.

Thanks for linking us up