Having to reconnect laser everytime door is opened

I’m new here so please forgive any oversight.
I am having problems with a newly overhauled Lasersaur, now using GRBL and an Openbuilds Blackbox controller. Every time I open the door I get this message [MSG: Check Door]. In order to carry on working I have to disconnect and then reconnect the machine. It does not do this when I use the Openbuilds controller. Is there a setting in Lightburn that I am missing

This is not a LightBurn setting / configuration. This is a controller feature:


Thanks for reply.
I have been through the set up process described in the link and I don’t have the same problem when I run the Openbuilds Control software. In Openbuilds control there is an unlock button in the gui, is there anything similar in lightburn?

Are you wanting to maintain the door protection? If your desire is to override the door protection, you could jumper the door output on the controller.

This thread is a bit dated, so maybe current versions of LightBurn are different. I live in the DSP world for my laser, so I am limited on familiarity with other controllers. @LightBurn may have more current advice.

I just want to be able to use the laser as soon as the door is closed.

Ideally I would like to be able to set up a job and run a frame with the door open but that doesn’t seem to be an option with out more components.
Thanks for you time .

Is there a possibilty to use HOLD, and connect the door to it?

Hi Thanks all for replies.
I solved the problem by making a single circuit of the chiller and the door interlock and connecting it t0 ground and WP. Works nicely now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.