High resolution photo not sending to controller

So I tried my first engraving with my new Thunder Laser HR head & to say I’m a little confused is an understatement. I’ve read that the HR lens has a dot size of .03". I tried to send a photo through Lightburn to the Ruida controller. It seems to send fine i select the file to open it & I get a message saying “NO DEVICE CONNECTED”. I was using JARVIS. So I sent the same photo at .05 line interval and it will send to and load onto the controller but when I output it I can see the lines from the passes in the engraving. Like the attached photo. from posting this on House of Lasers facebook group, I now understand different patterns create larger files so i probably hit some some of for file size limit so I’m going to try to send as newsprint today to see if that will work.

It doesn’t help a lot that image isn’t very good. This is the photo after I adjusted the midtone in my graphics software. I’m not sure how to get more perceived resolution, if anyone is interested here is the images I’m working on


They hype the .03 dot size but I notice they show what looks to be a dot on anodized aluminum. Remember that all not all materials are capable of a small dot even if the lens might be. You need to actually run some dot focus tests to see what the smallest dot is that you can achieve with the lens and material you’re trying to engrave on. With a lens setup like that, being off even by .2mm in focus height can mean the difference between a crisp dot and a blurry one.

Just based on the image you posted I’d say you’re not properly focused. I don’t see anything that looks like dots. If you zoom in closely you should see distinct dots if you’re using jarvis or stucki. It also looks like you’re using a rather rough textured wood. But maybe it’s just the photo making it look that way. Try sanding the wood so you have a smoother surface finish before engraving. What wattage tube do you have?

Also keep in mind that you see a lot of great photo engraving results where the face takes up the majority of the photo. Bulldog’s images come to mind.Then people try to engrave a photo like the one you posted above. They concentrate on the people’s faces when looking at the photo however that face is taking up a very tiny percentage of the pixels in the image. That means very few dots make up the face and accordingly the faces don’t have nearly the detail expected.

Dot Pattern

See that very small image I just posted above? Right click on it and choose “Save image as” to save it to your computer. Import it into a new project in LB. It’s VERY tiny. You’ll probably barely be able to see it in your workspace. Do not resize it. On the layer set it to passthrough, no dithering. Post your results here. You’ll need a magnifying glass to see the dots.

Here are a couple of my other posts with examples:

I’m actually very interested in seeing some results from actual users of this lens system you have. I have a different setup I’m pretty happy with but I’m very interested in seeing comparisons.

You say your new “HR” head. I assume that’s the BeamBuddy head I keep seeing posted.

Also, the images you posted above are obviously not the full resolution images are they? THe last image you posted above shows 720x960. Even at 254 dpi/.1 interval that’s going to engrave at 2.83" wide and 3.78" tall. Take it to 508dpi/.05 interval and it will be 1.41"x1.89".

Did you try sending the file a second time to make sure it was not just a comms error? I routinely send very hi res photos to my Ruida controller when testing the Beam Buddy head. I can easily send a 4" X 6" photo at 800 dpi / 0.032 line interval using Jarvis dithering. @LegacyLazer (Chris Loccasio) also uses the Beam Buddy head, and has no issues sending photos at 2000dpi using the half tone dithering in LightBurn. I find it hard to believe that your initial failure was due to the dpi setting of the photo.

As to file size, a 4X6 photo at 800 dpi, jarvis dither makes a ruida file of about 13MB, which is not that large, your controller should have no issues working with it, unless possibly the memory is full of other files that you have sent to the controller. You can try deleting some of the files off the controller and see what happens then.

Travis, thank you ill try that. It may be later today before I can get to try it or even tomorrow.

Anthony - yes i tried several times. It is pretty large about 6.5"x9.5"

Im typically brining the photo into Lightburn at 600-1000 dpi and with the BB lens ill easily be 1200-2000dpi to the laser on my 40 watt. I can see grayscale having an issue but not the halftone or dither processes

1 Like

What is the resolution of the original photo? I’d like to take a stab at engraving it on some wood. But the photo you posted above can’t be the original because it’s only 720x960.

Are there other files already on the controller? When Ruidas memory gets filled up with files it pretty much just “ignores” any attempts to upload more. You might try deleting any other files out of the controller and try again.

1 Like

Hank - Thank you, no I deleted all the files in the controller.

I am not following this workflow, can you please reword? Sending the file? Are you saying you are trying to send a file to the controller and you get this message?

If you do not have an established connection, you can not send a file.

1 Like

Yes thats why I’m confused. The file shows up on the controller but when you select it I get the message

Just so I am clear, you send the file from LightBurn to the controller. Once the file is on the controller, you try to select the file from the control panel, and this “NO DEVICE CONNECTED” message is then displayed on the control panel screen.

Do I have that correct?

Yes I have a short video I can send you but I cannot post it to this forum

travis here is the photo of the image let me know what you think

Thank you

You could put your video up on a publicly accessible provider, like youtube, and share the link here. :wink:

That’s interesting. It looks like your middle line is way offset from the top and bottom lines. What speed and power are you running this at? What is the length of any one of those lines on the material? Hard to judge scale without something in the picture to get an idea.

Without seeing a more magnified picture, and knowing what I do about that pattern, I’ll give you some analysis. In the original file all the pixels are .1mm. On the bottom line the pixels are spaced so that the center to center distance is .2mm. On the middle line the pixels are spaced so that the center to center distance is .4mm.

From your image it appears that bottom line of dots basically touch each other to make what appears to be a continuous line. In the middle row of dots it looks like you could fit another dot in the blank space between each dot. So if you think about that, it means that you’re putting down dots that are .2mm in diameter. If that’s the case then the highest DPI you’d want to run would be 127DPI or a .2mm interval. On that bottom row there’s a tiny section where you can just start to seem what appears to be white space between the dots. So you might estimate that they’re .18-.19mm in diameter.

I’m confused by the middle line being offset so much. I’d suspect that you ran this at a high speed or you’ve got some pretty good backlash somewhere.

A couple of things to try. Figure out the minimum power your laser will fire at and use that for your power setting. From there adjust your speed to try and achieve a dot on the middle and bottom line that’s as dark as the dashed lines on the top row. My guess is that this will slow your speed down from your test considerably. Reducing the power to minimum should also hopefully get you a slightly smaller dot.

To figure out what’s going on with that middle row try turning off bi-directional scanning and see if all three lines then line up

Also, if you have a moveable Z, take note of whatever your current Z height is. Use the jog buttons (in Lightburn) to increase the Z height by .1 or .2mm at a time and run the pattern again to see if you can get your focus any better (smaller dots). Then go back to your original Z and try decreasing by .1 or .2mm at a time (same thing in the other direction)

Basically, if you can get the bottom row to look like dot, white space you could fit another dot, dot, etc. then you’re getting .1mm dots and you can set your interval to .1mm. If the middle row looks that way then you’re getting .2mm dots (and therefore interval). From what I see, your middle row seems to look that way.

My understanding is that some modes (newsprint? halftone?) are more forgiving with overburn but to me they look “stylized”. For a more photo realistic looking result you’ll want to use jarvis or stucki with your photographs. But using jarvis and stucki you’ll get overburn if you set your interval any smaller than your dot size. When you zoom in close you want to see actual dots making up the engraving.

What you have there is not a bad result to start off with. What wattage is your tube?

Also, I asked a couple of times but never saw you respond. What is the resolution of your original photographs? Presumably they are bigger than 720x960.

Here’s what I mean about seeing dots in your engraving with jarvis or stucki.

If you look closely at the image above you can see that I too have a slight scanning offset problem I need to correct.

If you look at the last picture which was taken through the loupe you can see that any individual dot is just about .1mm based on the reticle scale of the loupe. This was done on card stock, not wood. I’ve yet to be able to get a .1mm dot on wood.

And here I went over to my machine and ran the pattern myself on a piece of birch plywood.

The above picture was just taken with my iphone set at 2x. As you can see it’s just really hard to get a picture of dots this small.

This picture was taken with my iPhone through a 10x magnifying loupe. It’s hard to take a pic through a loupe. Visually the dots look much better than the picture. But you can see that there is clearly white space between the dots in the bottom row (top row here since the image is upside down). Not enough white space to fit another dot, but still, significant. There is probably a 1/2 dot worth of white space between each dot. So I’m getting about .15mm dots on this plywood. Again, in real life through the loupe they look much sharper and much less halo.

Sorry i cannot remember the speed i ran this at. Ill be back in the workshop tomorrow and I’ll re-run it and try to follow your directions & see if I can figure out what resolution to run it at.

I have a 100watt Thunder Laser. The output size is around 6.5" x 9.5".

I know my laser will fire down to 10%

Thank you

If you’re talking about the dot patter, remember, don’t run it at any resolution! Run it in passthrough. Otherwise results won’t mean anything.

I’d def stick with 10% for your power then and vary the speed.