Laser keeps disconnecting on larger jobs

on small jobs there is no issue. But trying to engrave larger jobs it runs for about 5 minutes and disconnects from the laser. I have tried to turn off the USB power settings and that is not working. Have any advise on what im doing wrong?

Try running the job at a lower power setting and see if it makes it all the way through.

We’ve seen a lot of disconnection issues with Ortur machines and I’m not sure why they are so much more sensitive than anything else we support.

  • Use a good quality, shielded USB cable, preferably with a ferrite ring at one end at least

  • Make sure the USB connection is secure on both ends, not loose

  • Make sure the power supply is sufficient to supply the laser.

  • Ground the frame of the machine - one user found that the X belt was generating significant static electricity when running back and forth (engraving) and the discharge was resetting the controller.

Slowing it down and lowering the power seemed to help. It made it almost all the way through the engraving, But the laser still disconnected right after a mcafee ad to install showed up. This ad shows up randomly and I have no idea how to make it go away. Would that be something that could kick it out or was that coincidence?

It seems unlikely, but nothing is impossible.

So I got it to engrave the full image. I got a new data cable that was recommended. Slowed speed to less than 3000/50. Shut off USB power settings and screen savers. Uninstalled all adware and ads built into the PC. Once I get it grounded I think I will be able to increase speed and power cause a respond from the manufacturer recommended that it be grounded to avoid the static noise build up.

im having the same issue . Did you resolve your ,any help would be greatly appreciated thank you.

Have you gone through the list above?

IE, these: Laser keeps disconnecting on larger jobs

how do you ground the machine

Attach a wire from something metal on the frame of the machine to something that is grounded, like your computer case.

Same problem here, even though i’ve followed all the steps above. I keep getting an error:8 and the job stops.
This happens very randomly, sometimes 17 mins in the job, and sometimes 2 mins in. But on a 2h job, i get as much as 14 of these errors and i have to note the time, find the corresponding position in the Preview, and start from there.

Here’s the last one in date :

What i’ve done so far :

  • Grounded the machine
  • Disabled the USB power saving mode, both in Control Panel and in Device Manager
  • Tried other USB cables and USB ports
  • Checked both stoppers with the ‘?’ command (both work fine) and increased $27 to 3mm)
  • Lowered job’s Speed to 2000 and Pwr to 75%

I really don’t have a clue on how to solve this and it makes the machine quite unusable. Any help (at all) would be truly highly appreciated.

Thanks :slight_smile:

@OrturTech ? Any additional ideas? I know Ortur have released updated firmware with a bunch of fixes, so that’s one option.

Problem solved !!

Thanks to Ortur Support who did really great.

My problem was due to my grounding, which was not properly done. Static electricity bursts from the X belt’s movements was causing the disconnections/error:8.

We attached a copper wire on one of the 4 screws of the laser module’s top plate.
Wire then connects to a X-axis’ gantry screw. From that screw, another wire goes and connects to the Y-axis’ gantry screw.
Wires go through cable looms to keep everything neat.

Since then, several jobs ran full length without a single disconnection or error’8

So this might also help op with his problem perhaps ?

1 Like

Can you post pictures of what you did? Mine is also shutting down randomly

1 Like

Of course i’ll post detailed pics tomorrow :slight_smile:

Thank you!

Hey there :slight_smile:
So, following is what I did to scare those nasty error:8 away.

You will need :

  • Two copper wires a bit longer than your cable looms
  • A screwdriver
  • Optionnal : another copper wire with the length of your choice
  1. Secure the first cable to one of the laser’s module’s top screw, as in the picture below (blue cable) :


    It is important to use one of these screws, as they connect directly to the module’s aluminium frame and hence there is not paint that can interfere.

  2. Have this cable go through your cable loom all the way to the X-axis’ gantry and secure it to the screw as in the picture below :


    Use that very same screw to secure the end of the second wire (here it is the brownish one).
    This screw is a good one to use because it connects to the L-shaped iron thing which in turn is tightened directly onto the X-axis’ frame.

  3. From that screw, connect the second copper wire to the Y-axis’ gantry screw below the stopper, going through the cable loom. The connection in image (brown wire) :

This should properly dissipate the static electricity bursts. For good measure, I have also done the following but i don’t think it is necessary tbh :
a) Taped one end of a 3rd copper wire onto OLM2’s north frame :

b) Secure the other end with a nut of my 3D-Printer, which sits right next to my OLM2). This nut goes through the aluminium frame of the 3D-printer :

Since I have done all of this, I did not get a SINGLE disconnection or error:8 no matter the job’s duration, power etc.
I really hope this will solve your problem as well, because it is so irritating to have the job stop mid-way and have to note the time, find the exact place, launch from there and so forth.