Lightburn camera no image using "Custom Camera System"

I have the 8mp - W 120 official camera and I cannot get it to display a picture when custom camera system is selected in LB settings. If I switch to default camera system it displays but I lose access to exposure and brightness settings. I am running windows 10 and the camera is plugged directly into a usb port on my laptop. I have also ensured that camera access is enabled in Windows settings.
I have also tried running LB under Windows 8 compatibility and that didn’t make any difference. Any assistance would be greatly appreciated.

I often recommend starting with this post from the Lead Developer/Owner on camera troubleshooting in Win 10.

Thanks John, I have tried all the things mentioned in the post and still having no luck. I tried on another Windows 10 laptop and am having exactly the same issue. Is there anything else I can try?

I will post this on our internal channels and see what new things the Dev team might suggest trying.

Which version of LightBurn are you running on your Win 10 device?

I assumed it was 1.2.01 but I will need to confirm this for the internal processes.

Thank you very much, yes sorry it is v1.2.01.

I was having the same problem on windows 11, the camera was working on lightburn with the default camera system only, it was driving me nuts because it worked fine before and all of a suden it just stopped. It was not even working with the windows camera app.

Turns out the culprit was one of those “special” windows updates…
I updated again just now and it started working again, so give it a try, make sure you select the optional updates as well. I know this sounds like one of those generic solutions that you read in a forum that don’t usually work, but it did work for me so I guess it is worth a shot, give it a try :smiley:

Good luck!

1 Like

Thank you for the idea, I’ll give it a try tonight.


I installed all updates including optional ones and still no luck. Thanks for the idea, hopefully LB support will have something else to try.

Ah bummer :disappointed:
Other than updating windows I updated my graphics card drivers and directx. I basically did everything at once so I’m not entirely sure which fixed my issue. Might also be that the cause of your issue is entirely different from the one I had.

Anyone have any ideas John?

I gave it another nudge on the internal channel. I’ll escalate harder if I don’t hear back soon.

Hi John, any updates on this?

Staff had this in testing late last night - like really late. Nothing to report yet. The good news from a troubleshooting perspective is, that it went awry in captivity and lots of eyes were on it.

I’m sure they’ll be at it again today/tonight when their time-zones become active. I’m watching this closely for new patterns and procedures. Hopefully we can capture this and put a few more of these camera obstacles behind us.


Did they find any cause for the issue?

This is in part to bump the topic that has a staff response… but in scouring the forums I’m seeing a lot of threads that travel down a specific OS, but it appears there is an issue that (for a yet to be determined reason ) has the potential to impact all OS variations, and both “official” and “unofficial?” camera versions.

So I’m trying to get official staff info on the issue – which as best I can tell could be summarized as, “camera works on other OS apps, but only shows a black screen on Lightburn”… I feel like there should be some sort of sticky thread or announcement that compiles these various OS/camera discussions.

I would imagine that there are others that are also stuck with not knowing whether spending a lot of time changing the OS and/or the cost of purchasing an “official” Camera is likely to solve the problem…

And to clarify… I want to help however I can… just hoping that we can get one of the many great features working again. Thanks!

1 Like

I’m with you on all of this.
I’m getting a camera shipped out today or tomorrow to work on this as well.

If your camera is working in other apps and not in LightBurn - the next thing to test is the ‘other’ camera driver in LightBurn. Oz had some objection to the one that was offered so he wrote a different one and included it.

If you click Edit then Settings, you’ll see near the File Settings an option for the Camera Capture System. Please test both Custom and Default setups as the drivers offer different compatibility.

Is that a Windows only opton? I don’t see an option in Settings for Camera Capture Settings (just Camera Resolution, View, and Rotate 90) I’m using Lightburn 1.2.01 on Ubuntu 22.04.1 LTS. My cameras and operation are as follows:

Camera 1: Arducam IMX298 – Works in OS/Other Apps, Does Not Work in LIghtburn

Camera 2: Another Arducam, but shows up as ‘USB Camera’ – Works in OS, Does Not Work In LIghtburn

Interestingly, Camera 2 used to work in both the OS and Lightburn. In fact I went through the whole calibration process etc. However, I was having issues with updating Lightburn and other applications and needed to update my OS version. After updating my OS (from 16 LTS to 22 LTS), neither camera works in Lightburn, but both do work in other OS applications.

My best guess based on developer intuition and research (but not definitive evidence) has to do with security changes on the OS that would require LIghtburn to enable security settings in the OS software management settings which allow the user to provide camera access to the application.

I tried using command line options to provide permissions but either that path does not work, or I am applying them wrong, which is completely an option.

All of the above to say … I could try changing LInux OS, or a diferent camera … but based on findings so far, and researching the forum threads … I’m not sure another camera will solve it, and changing OS is a disruptive / time consuming option which also may not resolve it if this issue spans multiple OS, which from the forum threads it appears to.

Apologies for the dissertation, let me know if this should be reposted somewhere else … my initial goal on this thread was to make note that there are several threads on multiple OS, and felt like what was a needed is an umbrella/sticky topic that would look at the “camera works on OS, shows up in Lightburn, but only shows black screen” topic.



Anymore progress on this John?

2 posts were split to a new topic: Win 10 5MP LightBurn Camera Not Working (more)

4 posts were split to a new topic: Win 10 5MP LightBurn Camera Not Working