Lightburn for Mac

Hi All,
I have just received my Sculpfun S6Pro. I am an absolute beginner at Lasers I assembled it no problem at all, I installed the Lightburn Trial then when I clicked find my Laser (Turned on and connect to USB) I clicked “Find My Laser” but it just came back with an empty search box no Laser found, is there other software I need to download and install for the laser to be found? This is connected to a MAC

I also have a PC with Windows 10 so will try that one next.

Thanks heaps for any advice


I have this same issue with my M1. Can’t get it to recognise the laser. Works fine when I use my windows PC but if I could figure out the M1 issue it would be awesome

Some controllers are not automatically recognized by the LightBurn Software and must be set up manually. My new AtomStack X7 was this way.

When the auto find fails click GO BACK and then close that window.
Now Click on the CREATE MANUALLY button.
From the list of controllers select “GRBL” (unless you know yours is different and it is listed)
Answer the questions and then reboot Lightburn software with your laser device turned on.
The laser should respond by moving to the home position.
You can then finish setting up the software using:

Hope this will get you both up and running.

Great thank you, I will try this in the morning

Hi Williee

I have it installed followed the steps, then rebooted light room but it Cu.bluetooth-incoming instead of serial port ? This is the trial version not sure if that’s the issue?

There is no functional difference between trial version and fully licensed version.

What happens when you click the button that currently says “cu.Bluetooth-incomin…”? Can you pick the port that you expect?

You likely need a driver. The most common one used by diode engravers is on the 2nd bullet point here:

Unfortunately, not only Bluetooth is available, It has connected to my Windows PC in lightburn without issue but the windows PC is too big to continually move around. I need the mobility of the laptop

What version of MacOS are you running? Most modern versions should ship with needed drivers but you may want to explore that link that Oz has mentioned.

Thank you OZ I’m very new to lasers so a massive learning curve ahead, it’s working perfectly in Windows, but just need to get it sorted in MAC

I have exactly the same issue as above however I am using the serial USB port and Topwisdom controller with my M1 Mac. I have reset and rebooted Lightburn and the laser as advised above.

When I have added the device via “auto detect” or “create manually” it recognises the Topwisdom controller. However, when I send any files to the controller nothing happens - I have selected either the drop down “auto” and “serial usb” when trying to send files to the controller.

I have also deleted the above profiles and reconnected with my windows machine for testing purposes without issue.

I have also tried adding these Mac drivers as described here:

I think I am going to have to purchase a new windows laptop if I can’t get it to run with my M1. Happy to send through pics etc if that helps. Thanks Angie

UPDATE :partying_face: I have now managed to get the files to the laser controller via the serial USB connection and my Mac M1 :blush:(macOS Monterey Version12.1). I am running Lightburn version 1.0.06.

I have found that I can only send through very small files such as a basic 2 inch square or two to cut. Any larger files with more detail will not send. When connected to the laser, I used a serial/usb cable with electrical cable chokes on each end.

I also removed any files off the controller memory so that it was clear and also tried sending files via a USB A to USB A cable which did not work.

I think now basically I am having the same issues as mentioned in this post below. It seems that the Lightburn team have been unable to replicate the issue with their Macs used for testing purposes:

Has there been any further updates with this issue or with the beta file that was provided to the original notifier? Any advice would be much appreciated. Hope I have explained myself well enough - not sure of all the technical jargon.

Kind regards

Hi Willee. Thanks for trying to assist. I have done as directed but still no luck. Maybe Lightburn can assist me? I only bought my M1 laptop as others have said it works. Should have stuck with windows :sob:. Kind regards Angie

Nothing is more frustrating than a new toy that wont work right. … :confounded:

Just one more possibility … the USB cable … try a different one.
You never know … my connector had an intermittent problem that drove me nuts for a while.

I have used Apple computers since the 80’s and really like them.
The mac mini is small and powerful and in my opinion is the ideal computer to use with a laser engraver. Was so happy when I learned LightBurn would run on mac OS.
I hope you dont need to switch to a PC to run the software and hopefully the LightBurn engineers will find your problem and correct it.
Keep us posted if you do get it working as others may encounter the same problem down the road.

Hi Willee,

USB cable is ok, the laser is detected immediately by the windows PC, I work for an Airline here in Australia so I’m a shift worker but have this weekend off so I will install the software that OZ recommended and I’ll see how it goes .

Thanks heaps again for the help I’ll keep you updated

Since you have a DSP controller, not a GCode controller, your issues aren’t exactly the same. I believe the issues with TopWisdom on MacOS have been solved for the next release.

Awesome! Thank you for your reply. Hopefully the next release isn’t too far away and thanks for working so hard to fix the issues for us Mac users :blush:

Thanks Willee. I love my new M1 and don’t really want to go to Windows again if I can help it. Its encouraging to hear you like the mac OS. After many hours of sifting through the forums and trying out many suggestions I find am not alone with this issue. Thought I’d give it another try before I purchased a Windows pc. Thanks so much :bouquet: for taking the time to help out. Cross fingers the issue is sorted in the Lightburn release. Kind regards Angie

I seem to be having the same problem but with a NEJE 2S Max laser and Mac running Catalina. It connects fine with NEJE software, but I cannot get Lightburn to recognize it at all. I’ve tried downloading and installing the drivers repeatedly, restarting everything at basically every step, and pouring over every troubleshooting out there. I too can only get the cu.Bluetooth to pop up and then there is never a connection. Has anyone figured out a fix? I am dying to get to use my laser on a more in depth level!

You may want to review this Neje site about installing and confirming driver installs on Mac:
How to install serial driver on macOS – NEJE (

1 Like

I have tried this several times and it doesn’t seem to take. Do you have any suggestions?