LightBurn home location with xTool extension kit

After setting xTool’s XCS to the extension kit use and LigthBurn to the new working are size, the software does not know where the actual home position is. This is because (I think) that at initialization, the $132 parameter is not set to the new size. However, my question is if that is supposed to be set by the XCS or LightBurn.

Sorry I meant $131

Did you upgrade your firmware to include the extension kit?

Are you using the most recent lbdev/configuration file?

FW is at the latest versions in XCS and LB. No, I am not using the ibdev. I will follow your link and I hope there are instructions on what to do with it.

Jess, this ibdev is for D1Pro. Mine is the D1 basic one. Will that won’t mess up with other parameters like the laser power??

Have you tried this before any other manipulations.

Once the software is launched you must click on this additional settings tab and click read from controller.
It is useful to do this once in a while because the machine, like any other, loses this important data.

Merci scabb. Je me souviens de ta suggestion

Gents, About the issue with the homing, I have a question for someone that knows the software upside-down: Should we change 131 in this screen to 930?

Then you need a different a .lbdev profile, heres the correct link: Operate xTool D1 with LightBurn - xTool Support Center

That is the file I am using, and still, 131 stays the same:
406.

I would not change your y axis in your machine settings just yet. Are you following xtool’s instructions? Are they not working for you? The lbdev profile shows the home position being at the top left.

Answering your questions in order:
No, I am not following xTool instructions, that is why I am asking if I should or not do anything.
The device settings shows the correct setting unless I change it (that is how I have the canvas at the correct size)
Now, let me ask you a question: Do you have an xTool extension?

You should follow the instructions xtool provides, including using their .lbdev profile. It will solve a lot of your device profile/configuration problems. Have you updated the firmware in XCS yet? It would be wise to make sure you have the latest firmware installed on your laser too.

Thanks for confirming that you’ve followed their instructions for adding the extension in your device settings.

Can you explain why you think the software does not know where the home position is? Are you receiving an error, for example? Is your red square in the wrong place, it’s not in the top left?

I do not own an xtool extension. I understand why you think you should change your machine settings.

Now, it looks that we are going somewhere, and I apologize for not being more specific in the background information. My mistake.
Answering your questions in order: I definetly followed xTool’s instructions step by step, and to be honest, I still do not understand why they request to update the XCS and the lbdev. The way I see this is that if you hook up the XCS to the machine and set it for extension kit, right there is should write the proper data in the control board. At the same time you are requested to download the lbdev, which should do exactly the same. Now to the answers: I am running LB 1.6.00, XCS 1.7.8 on Windows 11. I also updated the D1 FW to V40.30.010.01 B2. I am using absolute coordinates.
Why I think the SW does not know where Home is: (Remember that my device settings are x 430, y 930) On connection the head goes to home (by setting) Using the position icon (Alt-L) I move the head to 308, 535. Now, I click Home the head goes to 0,363. I have to add two more things here: If after the Home taking the position 0,363 I request “get position” it shows me 0,0 instead of the actual position. If from 308,535 I request “Move to position” x0, y0, “GO” then it goes to the real home position.
Red square: It is at all times in the upper left corner, and also the green one.
Ok, Jen. I assume you know LB like the palm of your hand, and I am the unlucky guy with an xTool extension nightmare. On top I am an EE who has spent some time troubleshooting of FW and SW-based hardware, therefore and despite that, I have to finish a project which requires the use of this nightmare, I suggest we work together me as a field tech and you as the wise girl to fix this issue once and for all. What do you think?

Hold on on the positioning Jen. I did the test again and the “home” position changed. I guess I am getting tired. I suggest to provide you with results more reliable tomorrow.

Updating the firmware via XCS is the best option. My understanding is that when you update the extension in XCS you are writing to the controller the change. They “fake” GRBL firmware which is why is necessary for the .lbdev file. I will do more research and get back to you on your weird homing situation. Thank you for providing more details about your experience.

Well, up there, we are covered because I used the XCS to update the FW. so, that box is checked out. As a matter of fact, I tried to use the same object to cut in XCS and it does what it is supposed to do. I do not want to use XCS because is too rudimentary and lacks a lot of capabilities that I have in LB.

Now that you’ve updated the firmware via XCS, does LightBurn show any change to $131?

No, and keep in mind that I did all updates before I started this post

A toggle switch is mentioned in this post that you may have to enable in order to make changes to your laser configuration:

Please type into your console “$131= 930” and then type $$ to see if it is saved. My understanding is that xtool lasers prevent direct GRBL configuration changes, but at this point, I guess it’s worth a shot. Maybe if you run a job in XCS the extension part will ‘stick’?