Lightburn is mirroring the output to the rotary. Again. Still

The first few times I used Lightburn with the RA2 rotary all was good. Then it decided to mirror the output for no apparent reason. I got in the habit of testing each run with cardstock taped to the object. The last half dozen I had to mirror my image to get it right. This last job the Lightburn just ruined, I did just that - mirrored my image and ran a test run. It was fine. Loaded up the actual object to engrave, framed it, and started the burn. Lo and behold - it’s backwards. The only thing I changed between test and final run was the object diameter. WTF is going on?

1 Like

My experience thus far shows Lightburn randomly turns off “Mirror Output to Rotary”. By turning it off manually, closing the dialog, then turning it back on it sets things right again. I’ve found, so far, that if the preview shows the output mirrored it will run correctly.
Maybe some sort of masking error when setting other flags?

1 Like

I don’t know what’s going on in this case but it’s possible there’s a bug.
I’ll ask someone in testing to attempt to reproduce it by following your steps and try to catch this.

xTool D1 (Would you mind capturing the build info from the Console window so we can see which Firmware you’re currently running?)
RA2 Rotary
Win 10.

What are the steps you follow between stopping the cardstock test and starting the post-test version? I’d like to make sure we follow correctly.

This can be changed to be the right way around. Is the stepper motor cable long enough that you can turn the RA2 180 degrees and then put the tumbler in upside down? There are other ways - but this is very fast.

XTool D1:ver 40.30.003.01 B9

The only thing I do between the cardstock test and the post-test version is remove the test object from the rotary, insert the target object, and adjust power settings.
I fail to see what difference it makes which way the rotary is oriented when Lightburn randomly mirrors the output or not.

Was this ever resolved? It’s been driving me nuts, but this is the exact problem I’m having. I’ve run some testing between Lightburn and Laserbox. Laserbox works fine. Lightburn isn’t ‘sending’ a mirrored image…it’s rotating the chuck in the wrong direction.

Add in the fact that this seems to be an issue only at random times, and I think we can CLEARLY say that this is a bug with Lightburn and the RA2, right?

The best work-around thus far is to turn off mirroring in rotary setup, close the dialog, then turn it back on. Then, if the preview shows the image mirrored, it should burn correctly.

I’m not getting the intermittent issue you’re having. Everything works fine with my RA1, and both RA1/2 work correctly on LaserBox. But my RA2 with Lightburn always rotates in the wrong direction every time, without exception. So toggling the mirroring option doesn’t change anything. I either make sure the image is mirrored in preview, or I turn my RA2 180° so it rotates in the ‘proper’ direction (so JohnJohn’s reply above does work for me).

It’s not a show stopper, but it is a hassle.

I have experienced this apparent random behavior as well. However, I think I may be homing in on what triggers the behavior. It seems that if I change or even just view the Rotary Setup for a job after I have successfully engraved it – the mirroring function seems to stop (causing my image to show up backwards.) If I go back into the Rotary Setup, the next time I engrave the image, it comes out correctly. It is almost like there is a “toggle” being set each time I enter the Rotary Setup dialog. I have not tested this exhaustively, but my experience seems to validate this behavior. If someone has the time to test this out definitively, I would be very interested in hearing the results.

That’s pretty much what I’ve been saying.

I’m having this issue as well and it is not random. I am also using an xTool D1 with RA2 Pro rotary. Lightburn v1.1.04. (I’m ready to renew my license to get the software update once this bug is fixed :slight_smile:)

When opening a file in Lightburn, the “Mirror Output to Rotary” value in “Rotary Setup” defaults to disabled even though the visual slider in the “Rotary Setup” window shows enabled. This happens every time a new file is loaded.

Workaround is opening the “Rotary Setup” window and immediately closing it. No need to toggle the option, just opening and closing the “Rotary Setup” window seems to trigger the option to take its set/enabled value.

This was indeed the issue, and it’s been fixed. We use the same ‘output transform’ value to perform Print & Cut and the mirrored rotary output. When you create a new file or open a different project, the Print and Cut feature gets reset (because it would not longer be valid) but that was also disabling the rotary flip. I’ve added code to re-check the rotary switch and apply the mirror whenever P&C is reset, and it all seems to behave now. This will be in the next update (1.3.00).

It just happened to me again - the output was not mirrored even though it was set to mirror output. Fortunately I was just running a test on waste material.
I looked at the preview and it was not mirrored. Opened Rotary Setup and Mirror was turned on. Closed Rotary Setup without touching anything. Looked at preview again and it was mirrored.
Running a subsequent test, with the preview showing mirrored output, it did mirror the output correctly.
This was after running several jobs without issue over the last few days then clicking “New” to start a new test.

Still having the same problem as Clark. The only thing I have not tried doing yet is disabling the rotary and re-enabling it.

I’m chasing reports in 1.3.00.

Have you and Clark both downloaded the patched 1.3.00 that was released on Friday?

I have reported it to the team.

I just downloaded and installed the new update last night on my main machine so I am assuming so. Another thing to mention, is that my files were existing files. They were not new ones. I’ll try toggling on and off tonight to see if it stays working correctly.

I’m running the file I downloaded Thursday. I will update. Should I be downloading the release version or the beta?

2 posts were split to a new topic: RE: (70227 vs. 1.3.01 Beta) lightburn-is-mirroring-the-output-to-the-rotary-again-still

I’m running 1.3.01 and just ran into this today. Did a rotary burn last night on 1.3, the preview matched the output. Started the mirror problem today, updated to 1.3.01, mirror problem persists. .Now I have to turn mirroring off so that the preview is backwards for the burn to come out correctly. D1, latest firmware, RA2 Pro.

Not sure I completely follow what you did. If you’re using the RA2 Pro with the chuck and the motor is to the right, you need to mirror the output. If the preview shows the output mirrored it will burn right in my experience. If it isn’t mirrored, opening and closing the Rotary Setup window sets mirroring as it should be. No need to do anything else. Then the preview should show mirrored and you’re good to go.
The easiest fix currently is to just disable mirroring and spin the rotary 180°…