Lightburn not snapping to grid or object

I’m new to Lightburn and struggling as the software is not allowing me to snap objects together or even to grid, even though they’re toggled on in Settings. The crosshair does not appear when attempting to snap to object and I can place an object anywhere on the grid. I’ve tried toggling the settings on and off, closing Lightburn and rebooting my machine but the issue is still there. Does anyone have any ideas please, as this is really hindering me?

What are the distance settings for Snapping Behavior at present. Share a screen cap of that page for review, if you will. :slight_smile:

Hi Rick, thanks for your reply.

The size of the grid and the tolerance for snapping may interact in unexpected ways: the grid must be much larger than the snap distance.

Previous discussions may answer some questions:

For anyone else dropping by, The Doc:

1 Like

Well, that’s awesome @ednisley! I was just going to pull together some of these resources, but you are “jonny on the spot.”. Thank you for that friend. :slight_smile:

@rachael2050, all the above is worth reviewing. Below, I share a couple quick GIFs to show what happens when snapping in enabled on my system.

2023-03-16_14-54-47 (1)

2023-03-16_15-01-53 (1)

Thank you for your responses, I’ll have to have a trawl through the resources tomorrow. I’ve managed to get it to snap to grid now by changing the snap grid distance setting to 10, however snap to object is still troublesome. A quick question before I read through all of the other resources - should I expect this line to snap to the edge of the circle here? It’s snapped to grid but not object - am I just expecting it to function in a way that it actually does not?


Here I show alignment to the edge of the circle using snapping to aid in placement. In this case, grab close to the end of the line. Not the handle, but the line itself. :wink:

2023-03-16_15-10-20 (1)

Remember that 10 pixels isn’t very far across the screen.

On my 27 inch monitor at 2560×1440, 10 pixels works out to 2.2 mm. On a 14 inch laptop at 1920×1080, those same 10 pixels span only 1.6 mm.

Which is why I set it to 15 pixels: dragging within 3 mm of something is easier for me!

Very good point. You can bump those up a bunch to see the effects and practice the snap behavior, then dial it back down when a bit more comfortable.

This might help with “troublesome”, unless it is just not working for you at all. Then we need to investigate ‘why’ with you further. :slight_smile:

Thank you for your responses. I’ve tried it again today and it’s working. I must have been doing something wrong last night! :slight_smile:

That made me chuckle and almost spew my coffee! LOL

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.