Lightburn vs Full Spectrum

I have a legacy Full Spectrum Pro laser, stock, running their proprietary software (Retina Engrave 3D). The company is one of the worst I have ever dealt with! Their support is awful, they only care about new customers and not existing ones. I have a machine that cost close to $10,000.00 and when I have a problem of any size, the process is to send and email describing the issue and they email you back… this usually takes about 3 -5 days. For a professional, this often means I can’t meet deadlines.

My question is, if I convert my machine to use with LightBurn, is there any support offered with the software?

There is endless support for lightburn software. You may even get some help for your laser from some of the members here.

Over the years, I have used a lot of software. The support from lightburn users and staff is second to none!

Lightburn only supports certain types of controllers. Do you know what is inside your machine?

Here is the supported controller list…

We currently support most Ruida, Trocen, TopWisdom, and GCode based controllers. Supported GCode controllers,include Grbl, Smoothieware, Grbl-LPC, and Marlin. Supported Ruida controllers include the RDC6442G/S, RDC6445G, RDC6332G, RDLC-320A, and R5-DSP. Supported Trocen controllers include the AWC708C, AWC608, and TL-3120.

If it’s one of the supported controllers, Lightburn will work…

If not, then you could probably purchase something like a Ruida and replace the current machines controller with it.

You can get a ‘trial’ version of Lightburn …


I have a similar situation. Purchasing a FS Laser PS20 was a terrible decision. In order to salvage my investment I upgraded the controller to a Ruida 6445G. I use Lightburn exclusively. Here is my basic setup:
Ruida 6445G
New laser power supply
60W 1250 tube
I kept the Full Spectrum settings on the DM442 drivers (X and Y at 20000 PpR, Z 1600 PpR). Micro stepping X and Y at that level seems excessive, but it works.
The conversion was tedious but not difficult. The only thing the Ruida diagrams missed was the ground loop on the laser PS.

My machine calibrates and works flawlessly in linear mode. I have two problems I need help with.

  1. After using and calibrating my rotary, the Y axis will only move 300mm. I have to reload my default machine file (no rotary setting).

  2. When I calibrate the Z axis, it will no longer respond to the controller (only through LB).

FYI the rotary and the Z axis motors are the same. They are not the NEMA 17s that are on my X and Y. However they worked correctly prior to the controller upgrade.

Input or ideas welcome.

May I ask some specifics about your conversion? Is a new power supply required for the conversion? When you say you kept the FS settings on the DM442… what do you mean and what is the DM442?:grimacing: Any other insight to the modification would be greatly appreciated!

I replaced the laser power supply because I was upgrading the 45 watt tube to a 60 watt. The original power supply would have worked, but I wanted a better quality unit. I did not change the 24v power supply.

The DM442 is the model number of the stepper control. The settings referred to are the dip switch positions.

If you are just replacing the controller with a Ruida controller, no other parts are required. The wiring diagram with the Ruida will guide you. Just remember to replace the ground jumper on the laser power supply (this is missing in the Ruida diagram).

Full Spectrum also uses a 5v power supply that will no longer be required. It is located just above Full Spectrum control box.

Hope this helps.

Thank you so much, I think this will be very helpful! I am fed up with Full Spectrum… they are absolutely awful!

We’ve heard this many times, from a considerable number of people.

We won’t necessarily be able to assist with hardware issues, but in general if you email us (or post here) someone will try to help.

Hi Oz,

Herein lies the rub, I can’t determine if its hardware or software related. Here is a more detailed description of what I am experiences. The rotary issue is the most important. I can live with the Z axis not being calibrated.

Initial settings;
Ruida 6445G controller (RDC-V15.01.19)
Lightburn V1.3.01
X and Y calibrated to 0.01%

Problem: Once I enter values into the rotary setup window to correctly size the engraving, the rotary will run perfectly. I disable the rotary and power down the laser. I change the aviation connector back to the Y axis connector. I power up the laser. During the initial reset the Y axis will not return to home (if it was left further than 300mm away). I tried manually tripping the limit switch with no effect. When I move the Y on the controller it will only move 300mm.

My stepper motor driver is set to 20000 pulses per rotation.
LB rotary setup is 25680 steps per rotation and roller diameter is 34mm.

After using the rotary, I have reload machine settings to my default file (no rotary setting changes from default). Once done, the Y axis responds correctly until I go to use the rotary again.

I am interested in your thoughts.

Do you ‘hot’ swap the Y axes for the rotary?

What does the machines console indicate?

Did ‘it’ think it home properly or was there some type of error?

The Ruida should home before anything else when it’s booted. Assuming homing for that axes is not disabled within the controller itself.


The console showed 300 mm moved on the Y, but continues to try to reset. Eventually I hit ESC. I do not “hot swap” as a general precaution.

Do you disable homing or press esc when you attach the rotary?


I have tried 2 techniques. !. manually trip the Y limit switch twice to emulate the linear motion. 2. Press ESC. Neither technique changes anything.

I do ok with the Ruida, and I’ve never heard of one acting as you describe.

However they continue to surprise me with their operations that are not ‘expected’.


I have also considered adding a 4th axis (U) assigned to the rotary. Although the 6445G shows the capability, I can’t find enough information to clearly know if it will support this function. I assume (dangerous word) the “A” setting the the LB rotary pop-up would correspond to “U”,

Browse this link, maybe it will be helpful with the rotary.


So… my initial question was regarding the support, which is clearly much better here! The ironic thing about where this thread went is that one of the main issues I have on my Full Spectrum as it stands is my rotary. Currently, I swap the Y axis when using the rotary. It sometimes works and sometimes give very unexpected results, particularly when rastering. So, if I want to keep my setup the same (e.g. not deal with a U axis) and just change the plug… what controller will I need? Ruida 6445 S or the G?

Before you commit, take a look at this video. If I didn’t already have 2 6445g DLPs, I would seriously consider this touch screen Ruida.

That looks great! Thank you so much!

For anyone reading this who is looking at Full Spectrum, at this point I called them over a week ago. I submitted the support ticket, sent photos and videos of my issues, and have emailed them a few times. They have yet to reply. Conversely, on here, where I haven’t even made a purchase yet, I have had multiple users reply as well as staff. Don’t be fooled by FS Laser’s sales dept, they are a terrible company!

We have an 80W FSL at work. I would LOVE to use lightburn instead of their crappy software that isn’t even supported anymore. Unfortunately, getting someone to spend the money on a Chinese controller to modify the machine to run 3rd party software (which would also need to be approved by IT) is a tough sell. Burocracy for the win, I guess. The FSL software has so many bugs.

We never used a rotary attachment, no I can’t offer any help there.