Orientation of rulers

Hi there!

Can anyone tell me if there is a way to reverse one of the rulers’ orientation ?

My Chinese 100w laser’s default ‘home’ is back right corner. I have been able to switch the orientation so that I can work out of the back left corner -seems to be more logical-. Lightburns vertical rulers are just fine as both orientations work from the back of the workbed to the front , so the ‘0’ is on top… but for the horizontal ruler, Lightburn takes ‘0’ as the original machine’s ‘home’ and I would like to have this at the back left too … Is there any way to change this?

Hope you guys can help me …



Change your machine’s home setting and the home position in Lightburn.

Wouldn’t that cause the machine to try to home the axes in a different corner too (where there presumably are no reset/homing switches)?

Well I’ve been through the machine’s manual over and over and I can’t chance it’s home position… and only changing this in Lightburn results in all my projects being processed mirrorred :frowning:
And as @mlenstra stated , there are no switches in that corner …
No , everything works perfectly, It would just be nice if the ruler in the software was reversed and counted up from left to right … that way, I can already see in the software how big an material I have to put into the machine for my project to fit… It’s not like it doesn’t work like it is … just takes one more step to calculate material

It’s basically assumed that you will always be positioning your material closest to the origin point, wherever that is on your machine. And it’s not really a ruler, it’s a representation of the coordinate system of your machine, which starts with 0,0 in the top/back, right on your system.

1 Like

I know this , but calling it a ruler was a lot shorter :wink: … and apparently you still know what I was talking about , right ? :wink:

I get the whole Idea , but for a Belgian -used to reading left to right, top to bottom- the chinese oriented system wich is based on reading right to left , top to bottom isn’t logical to work with.

Also it makes it quite difficult to orient workpieces if they have to go in a second time.

But , as I stated before , it’s nothing critical … I can work perfectly as-is … it would just made life a little bit easier :slight_smile:

thnx anyway on your input though

Yeah, totally get what you are talking about.
Don’t understand why it’s “difficult to orient workpieces if they have to go in a second time.” though… why not just always orient them at the origin of your machine?

If I uses the machine on it’s defaults , everything gets cut or engraved mirrorred … f######ng chinese logic I guess ? :slight_smile:

If it’s mirrored, that would mean that your origin in LightBurn does not match the actual origin of the machine. As long as those match, you will be fine.
Is the origin of your machine not top/back, right as shown in your screenshot?

yes , it is back/top right it’s native origin, and via the settings in lightburn I was able to swap this to top/back left. The fact that is was working mirrorred had nothing to do with Lightburn’s settings , as it was even so with the default software (and there orientation/origin was not changable) … and it even happened if I wanted to engrave an image straight from usb… I even went so far as to check the wireing to see if they hadn’t switched some wires during assembly. A friend of mine bought a similar machine from another chinese vendor : same issue. It’s there for we went to look for other software and stubled on Lightburn where we at least could change this

Oh weird. But yeah, LightBurn must match the machine even if the machine has a weird origin placement :stuck_out_tongue:

I’ve actually never seen a chinese laser with an origin like that. Mine is back, left - and I think the K40 is front-left like a CNC machine.

Most Ruida based machines that I have seen default to the back right for machine origin.

nope, in my K40 is home top / left … there are many options :wink:

Well, some of them home to top/left but the actual origin is front left. Homing location doesn’t need to be the origin.

1 Like

Dude, I’m a Belgian ,… we’re specialised in ‘Weird’ lol … what else to expect from a country with only 10mil inhabitants but need 5 complete governments … well … ‘need’ … we don’t need them, but they all think they’re important anyway :wink:

It changes the origin. Whether your machine has estops in that position is a different issue. Mine does.

The ruler follows the origin. 0,0 is where it is, the ruler counts from there to the extent of the axis.

Most Chinese machines are set up to home right-rear. most US/Euro left-rear.

I forgive you for the Square in Brugge on an august afternoon, the Trappist monasteries, the beer sellers with 500+ varieties to choose from, the forests of the Ardenne, the beaches of Ostend, Spa, mussels and chips, polite drivers, wonderful roads… but not for Brussels. You can keep Brussels :wink:

And an hour or more of exploring every possible configuration of a Ruida controller to somehow maintain Right Rear homing and reverse the X axis coordinates resulted in two outcomes:

1 Like

@ Tom Vervynckt

I had exactly the same issue, and raised the same request for an enhancement to Lightburn but was rejected. I suspect the issue isn’t obvious to understand unless you face it.

My Redsail/topwisdom used Autolaser. This oriented the rule correctly (0,0 on the top left of the page).
For some reason Lightburn seems unable to do this.

Right now, I have to place my work items on the laser in a top left (so it’s close to the exhaust, and just my preference) but the working coordinates are X700, Y0. This is REALLY annoying when you measure the material to cut (e.g 100mm) and have to subtract this from the 700 when look at the screen when making sure it will fit.

Surely this can be fixed in software!?! It’s my only grump with Lightburn.

I considered moving the homing switches to the other side and changing the controller settings but that’s not easy either.

@Oz can we request this to be looked at again? Not sure if I articulated the issue well enough previously.