Ortur Laser Master 2 Alarm 2 Line 4

Just got an Ortur Laser Master 2, bought LightBurn and am having issues with it. At first it would cut fine but now I’m getting an Alarm 2 at or near Line 4. I’m not sure what Line 4 is so I can’t determine what is out of bounds. It homes fine, but won’t stream. I then thought it might be the firmware because the first time I added the laser, the software added it as GRBL. When I deleted it and tried to readd it to fix the problem, it said the GRBL needed was the previous version. 1.1 or something. So I went to the forum about updating the firmware, followed the directions and it won’t let me copy the OLF_000.bin over to the laser.

Thanks in advance for your assistance.

Alarm 2 again (sorry!) ------- ?

Tried that. Now I get a homing fail alarm 9. Then it says

ALARM:9
Ok
Ortur Laser Ready!
GRBL 1.1 [’$’ for help]
[MSG: ‘$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

Tried what, exactly?

Don’t change the homing directions - put the software in ‘Absolute Coords’ mode instead of ‘User Origin’ or ‘Current Position’. Read here: https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

Putting this in console:
In the console window, type:
G10 L2 P1 X0 Y0

It’s in absolute coords. It’s giving alarm 9 now. The ortur is homing forward and to the right instead of forward and to the left like it should. I’m still getting alarm 2 near line 4.

The $23 setting needs to be flipped - If it’s odd right now, make it even by subtracting one. If it’s an even number, make it odd by adding one. That is toggling the bit that controls the X direction.

In the LightBurn machine settings (0.9.15) these are properly broken out into individual flags you can just flip with a switch.

Fixed the homing issue.

Still getting Alarm 2, Line 4.

$0=20 $1=50 $2=0 $3=1 $4=0 $5=0 $6=0 $10=1 $11=0.050 $12=0.002 $13=0 $20=1 $21=1 $22=1 $23=6 $24=600.000 $25=3000.000 $26=100 $27=2.000 $30=1000 $31=0 $32=1 $33=250.000 $100=80.000 $101=80.000 $102=80.000 $110=9000.000 $111=9000.000 $112=9000.000 $120=2200.000 $121=1800.000 $122=2500.000 $130=160.000 $131=150.000 $132=1.000 ok ok Starting stream Layer C00 ALARM:2 On or near line 4: Stream completed in 0:00 [MSG:Reset to continue] Waiting for connection... Waiting for connection... ok ok Homing ok

Show a screen shot of your main window with the Laser window visible, and the project you’re trying to run.

@PlaneAndSimple have you firmware updated your machine
If direction of homing is wrong on stock settings, it might mean you applied a wrong firmware to the machine.
In fact by your $$ settings you can see you have 150x160 max travle set
Please let me know so we can arrange a firmware fix for you because clearly your firmware is incorrect for your machine.

I have updated the firmware with the firmware from Ortur laser won't turn on after attempted firmware update

Hello
Can you tell us please what machine you tried to update youf firmware update? MAC?

also why did you try to update your firmware please?

I used MAC. Had trouble updating it so then I used Windows and had to go through hell to reset with the 0.0 file and then reinstall the updated firmware.

I updated it because I was having the alarm 2, line 4 errors. According to other posts on this forum, updating the firmware for the ortur was recommended.

The latest version of the firmware is 1.37 - although not a diference from what you have since 1.34.

I assume however that you are still having problems

In console can you toggle the “SHOW ALL” then type $# while connected, Press enter and copy paste the output of console please?

Regards

Hi OrturTech,

It is updated with 1.37. I ran $# which revealed:

Waiting for connection…

ALARM:8

ok

Ortur Laser Ready!

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

ok

[MSG:Caution: Unlocked]

ok

$#

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

Looks to me the firmware is 1.34
Alarm 2 tend to be wrong job origin.machine “thinks” it will hit the frame so triggers soft limits
besides that.

the problem it seems to me is you have a OLM2 400x430 and you firmware updated it with OLM machine firmware, which is 160x150
So for SURE you will have problems.

Any way you can contact me directly (Gil Araújo) on our Ortur User Group in facebook, we need to firmware update it propper. But you will need a WIndows machine for that purpuse

This is the issue we need to resolve. Also your homing movement should be going away from the limit switches not into them.

Will give you a ton of problem.
Unless i am reading something wrong.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.