RESOLVED - Lightburn 0.9.22 - Shift box which is replaced by power and speed adjustment

I understand that having the same program for many machines, and having to work with different systems, often there are dialogue problems.
What I don’t explain instead is why to radically change the user interfaces.
Nice to have the possibility of a function, but can only be recalled if needed.
I don’t use the function to change speed and power in execution, just that it exists for those who want, but in my opinion, it should be visible at the user’s request.
Then I might want the “mask image” function every time I work on the image, but others may not find it useful.
A question of utility.
However, for the moment I have no other questions, so I thank all those who have participated in the answers.
Thanks.

I believe this is exactly what we have provided.

Yet, also understand this additional option to adjust “on the fly” is not what you are requesting. The resolution to this observed “Move button push” behavior has been identified, modifications implemented, will be tested, then we’ll provide the fix in our next release. :slight_smile:

1 Like

Ah, I see.

That would get annoying. And thanks for the tip about the shift button - I didn’t know it modified the move.

The fix for this was released a couple of hours ago with the 0.9.23 release.

1 Like

@LightBurn Thank you for the fast response. I will check it as soon as the current job will finish tonight

@LightBurn All, i am sorry to report that the problem is not solved in 0.9.23. I just installed it and the problem is still there

1 Like

Hi, I wanted to write the same thing.
I have installed version 0.23 and the result is the same.
If it helps, I have windows 7 Ultimate SP1 - 32 bit.
Thanks for your attention.

Thank you for the fast response. I will check it as soon as the current job will finish tonight

Hi, I’m also sorry to write it, but nothing has changed with version 0.9.23.
It’s like before, every time I use shift or frame, the speed-power control card opens.
I use 32-bit windows ultimate sp1, and 64-bit windows ultimate sp1.
On both PCs I have the same result.
Thanks.

Which version are you using? (Windows 64 bit, or 32 bit, or … ?)

It did change - the move arrow buttons no longer cause this panel to appear, but framing still does, because framing commands are sent to the laser as though they were a file. I’ll clean this up.

I use 32-bit windows ultimate sp1,for Pc one, and 64-bit windows ultimate sp1 for pc two.

This is fixed for the next release.

1 Like

Will it be fixed in version 0.9.24?
I would like to ask, when changing the speed or power with the arrows, from the panel containing increases, where do I see the new settings?
Thank you

I updated to 0.9.23 right now. I just signed up on the forum to let you know the Move area still glitches to Power and Speed control settings when I jog my machine.
K40 Laser with Awesome tech MiniGerbil. Windows 10 64-bit operating system.

Thanks for working 24/7 to patch the bugs. I love your software.

You don’t “see them” unfortunately - GRBL gives no feedback at all as to what the settings were changed to, and the increments can be customized in the firmware. I considered making LightBurn attempt to track the values, but it might not work correctly.

1 Like

@LightBurn . By the way, I went back to 0.9.20, and the problem appears there also. Is it going to be fixed in 0.9.24? What is the ETA?

Thank you for our great work