Ruida Rotary settings, 6445G, U-Axis, RA2 Pro

i have problems with my ruida board and my new rotary
for the time being i connected it and moved it with the arrow keys in the movement area
Screenshot 2022-08-10 155847

I was able to determine here that all movements X/Y/Z and also the rotary are possible without any problems

also under
Screenshot 2022-08-10 154755

However, when I tried to press the test button here, only X and Y moved. The rotary did nothing here, even when I tried to laser a test, the rotary did not move
what can I do to get a correct rotary laser

maybe someone has an idea?
kind regards Stefan

How did you set this up?

Your rotary should have the steps/rotation set to whatever the motor driver is set…

On mine, I have a PiBurn, it’s a ‘wheel’ rotary so it has an extra set for initial setup. For yours

Read switches from rotaries axes motor driver, pay attention to the ON direction on the switch…

Compare it to the placard table…

If this was your rotary, you would enter the 2000 in the steps/rotation. Your numbers seem rather large…?

When you press test, it should rotate the chuck one complete turn then return…

Good luck


That’s exactly what it is when I press test, my rotary doesn’t turn, but then the Y moves
especially since I can move X / Y / Z and rotary correctly with manual movement
but I can’t select the A when setting up rotary
on the other hand, my rotary chuck and roller can be used, which would be great if I could adjust both because the steps per revolution are different

my rotary

Steps/rotation is not motor, it’s the motor driver.

What axes are plugged into?

Which controller? Are you sure it’s a Ruida? If so which one?


yes it is a ruida but i don’t know exactly which one at the moment

Your rotary cannot be plugged into three axes…? Which ONE is it using?


U axis
Screenshot 2022-08-11 094410

Screenshot 2022-08-10 162142

I don’t care if the axis is called A or U as long as it does what it’s supposed to

when you move it manually it does what it should
which means for me that the right axis is recognized

I don’t know why this is the case with this test
and even then it is not the case with round lasers

and what I can do about it, that’s why I’m writing here

What controller do you have?

ruida bord RDC6445G(EC)

Give this topic a read.

The endless quest for rotary engraving on Ruida 6445g - LightBurn Hardware Compatibility [OFFICIAL] / Ruida controllers - LightBurn Software Forum

Unfortunately, this is not the case for me because my rotary does not move at all when lasering, not even during the test

my rotari only moves manually

If you don’t know (or care) how it’s connected, someone else will have to help you. Without the information I cannot, it’s a waste of time for everybody involved…

I highly doubt the diameter of your object is 80,000mm…

Good luck


I said that the program should already know which axis is used to control my rotor, it is the U axis and the diameter of 80 mm is only there so that a diameter is specified at all, but that only leads away from the topic, namely that the rotary (U axis ) in the test and when lasering does not drive what it should
During the test, the Y axis, which should not move during the test or during rotary lasering, only moves manually to move home from the workpiece

I’m thinking you need to set it up as a roller. Even though it has a chuck it’s still belt driven.

Would you please stop the ads

There was a malicious link in the thread which has been deleted. The individual that posted it has been blocked from posting again and their account has been deleted.

If you’re getting strange advertisements and pop ups on your computer please use a virus scan tool to remove any malware that may have been launched on your computer.

1 Like

Try turning your Laser Machine Off and On again while the Rotary is plugged in.

Thank you :+1: :+1: