Speed problem in lightburn

Hi members i am a beginner asking for help i just use lightburn and when i laser letters these go at 3000mm / min speed and can adjust the speed too.
See movie 1.
Lettering gcode movie

But when I load a photo into lightburn and save it as gcode and start it up it goes very very very slow, I know that a photo has more dpi.
But my speed in lightburn is 3000mm / min and it should go very fast but it is so slow.
See movie 2
Photo gcode movie
Who knows, based on my setting photos and videos, maybe whether I have something wrong.
I have a diode Optlasers 6 watts.

I hope there is someone who can help me with this I am stuck and do not know how to proceed.

Thanks

My settings photos maybe i did something wrong there, if so can anyone make adjust on photo in paint so i can learn how it must be .
Or i maybe have a page forget in foto that i must have to correct the settings i hope anyone can place it in comments.

Thanks for helping.

!

Hi, it looks that the laser “waits” after every gcode command. I don’t know why (my laser is not g-code based, I have trocen controller), but it’s similar to some issue, which I had to solve. It was “blow delay”, which caused my laser to blow some time after finished line, than move to another shape. The decrease of the speed was very huge.

Hi i have printscreens of my settingmaybeyou can point it on my photo where i can change that?

Most CNC systems designed for use as woodworking tools use the S parameter to control the Spindle (rotary tool) RPM. When it changes, they pause to let the spindle speed up or slow down to the new RPM. If you replace the spindle with a laser, the CNC controller has no idea you’ve done this. GRBL firmware has a setting specifically for lasers (laser mode - $32=1) that tells the controller not to pause on speed changes, because that value is now used to control the laser output power instead.

The letters work because the spindle output value isn’t changing, it’s just using the same power for the whole letter, so there’s no pause.

Your profile says you have a UCCNC controller - I don’t know if that controller has a laser mode equivalent, but I’d contact whoever makes them and ask if there’s a setting for it.

Yes I use the Uccnc laser version.

But you speak about $ settings where I can change values is there a tutorial for what settings what is ?

Yes I have uccnc, but I use a very simple gcode generator software also made for laser only and there in if I change the speed value then he respond on it also In photo mode but when I do it in lightburn he does not respond on every lower or higher speed change I make in the lightburn software.??


maybe here? (and probably end the line with semicolon, I just wrote it without)
Tutorials are available at google.com - type gcode :wink:

I don’t know what you mean in your last post???

Edit -> Device settings -> GCode
There you can write down some gcode commands, which will appear at the start/end of every drawing you send to your laser.

Can you post or email us an example of the GCode for your system that works the way you think it should? GCode for a photo that does not pause.

This gcode i have made it in Vectric 9.5 and that works perfect no problems add all, but i cannot make in vectric a toolpath for a photo that i want to laser.
Because in vectric 9.5 that is not possible.
Thats why i want to step over to Lightburn and because lightburn has more filters inside i want to use.
Like ( Jarvis, Stucki, Dithering etc.)

The post processor is.
Stepcraft laser Dll450 mm.txt

That is special made for Uccnc users.

What i we’ll found out in the gcode that turn on and off the laser is that M3 must be M03 and M5 must be M05 in the gcode.
But wen i try to laser the file then the speed is not adjustable in any way it only get very very slow.
I putt many values in there but he does not respond to that increase or decrease speed values.

I hope that Lightburn can make a new device possible in the way to choose in list Uccnc .
Because Grbl and Grbl- M3 and all the others does not work for Uccnc users. I want to save the file from lightburn in .txt and then i can load that file into Uccnc to let it work.
Thank you that you are trying to get a solution.

Lightburn-vs-Uccnc.txt (55.0 KB)

I also try that but made no difference.

Hi that will only work when you have connect the laser to Lightburn i already try that but no luck. I only want to use lightburn stand alone and want to save a file from Lightburn. And then I go to Uccnc and load the saved file to let it work. But thanks for your Tip

I’ve been chatting with Mateusz and he’s given me the info I’d need to make output for the UCCNC. Do NOT follow the advice of people here telling you to change your $ settings - you don’t have them, and they won’t work.

I’m really happy that lightburn is willing to make a uccnc device setting into lightburn and I will wait for the message from you. And I will not do anything with the settings. Thanks

@andre99 Sorry for the bad info. Since you said that you were “tying to laser the file” I didn’t understand that you were not using LB to actually burn the image.

Oke I will wait for you when you have news around the making of a new post processor in lightburn for Uccnc. Thanks

Already something found out ?

No - expect this to take at least a month.

Oke thanks for the info I wil be happy to hear from you
Thanks for helping .

Lightburn is a direct software and when is save the file, but when i do that with a image the power off the laser stay the same all gcode long so that is wrong but also other Letter such as S must be Q M3 must be M03 M5 Must be M05 that are the faults i get.
I make a Photo but the S value stay the same only full power??