Updated to 0.9.23 and cannot send jobs to laser

We know the 0.9.20 version works - we’re much more interested in whether the newer 0.9.23 / 0.9.24 versions work. I think the Big Sur specific builds will have camera issues, but the non Big Sur version should work.

I’ve updated the above links to newer versions, and I’m repeating them here:

Ok, these links are to the various test builds that will eventually become release 0.9.24:

Anyone having issues with the current release, please download from the appropriate link above, try it, and post your feedback in this thread with the following info:

  • What version did you download?
  • What OS and controller do you have?
  • Did it work, or fail?

I’ve tested this on all the systems I have, and it has worked for me. This does not address the issues with camera connections on Big Sur, but the Mac (Older) version might work for that.

I tested these versions: 0.19 0.20 0.22 0.23 0.24 and on all of them I noticed this problem:

GRBL firmware, ESP32 card, Active buffer, Baud rate 250000

254 dpi raster image, stucki, size approx 270mm x 110mm speed 300mm, from lightburn run time approx 15 minutes and very jerky x-axis.

Taken the drop and processed in Lasergbrl and run time 10 minutes and fluid X axis.

I think there are serial management problems in lightburn …


Do you have Laser Mode enabled? ($32=1) If not, that would explain the jerky X axis.

I also am having issues with builds 0.9.21, 0.9.22, 0.9.23, and the test build 0.9.24 in this thread. All I get is “Waiting for connection…”

I’m using Windows 10 64bit with the latest updates and patches, and the 64bit version of LightBurn.
I’m running on an LPC1768 with the latest version of Marlin, complied from git hub today and the following settings in lightburn:

I’ve also tried with and without DTR (I normally have it on)

Edit: Versions 0.9.20 and below work fine for me

@rvarone everyone else is falling back to LightBurn v0.9.21 or v0.9.22 and things are working well again.
Since you just built the latest Marlin and no versions of LightBurn are connecting, maybe it is your firmware. So any of the free G-Code sender apps work with your setup or better yet, do you have an earlier version of the firmware which worked so you can validate LightBurn can still connect to that known working firmware?

yes, $32=1

  • What version did you download? 0.9.20 - 0.9.22 - 0.9.23 - 0.9.24 same problem
  • What OS and controller do you have? Windows - ESP32
  • Did it work, or fail? Work

Sorry I forgot to include here that versions 0.9.20 and below work fine for me, my issues started with 0.9.21, I had another thread and Rick told me to post here instead.

This is likely because you’re using the GRBL device profile in LightBurn instead of using the Gerbil profile. The Gerbil profile knows that your machine needs the “Enable DTR signal” button set, and the GRBL profile does not set that for you.

Instead of using LaserGRBL to process the image, use LightBurn, and have LightBurn save the GCode, then send that GCode from LaserGRBL. If the issue is serial management, then this would work. If the issue is NOT serial management, then LaserGRBL will produce the same jerkiness.

What is most likely happening is that you have not processed the image with the same options, and LaserGRBL is producing much smaller / less dense GCode, and is able to keep up with the 300 mm/sec rate you have asked for, which is quite high for a GCode system.

Worked for me - thanks!
I downloaded the MacOs (Older) for my macOS Catalina Version 10.15.7. I use a Ruida RDC6445G as a controller.

I guess you didn’t read that right.
I confirm that I have given the lightburn gcode file in process otherwise I would not have reported the problem.

I am attaching the videos with the same gcode, one run on Lightburn and one on Lasergrb (same hardware and same parameters)


I have installed the MacOS (Big Sur) version of 0.9.24, and have not encountered issues I was previously… I could do a simple line on 9.23, but any more complex, it would stop part-way through, or not go at all. I have done some cuts/engraves now without any issues with 9.24. I have the KT332N controller (detected as 6445)

Can you send the project file and the generated GCode from your machine to support@lightburnsoftware.com so I can have a look? I don’t have an ESP32 / GRBL variant here, so I might have to try to figure out how to set one up.

I finish doing some tests and then turn everything to the support.
Thank you

I have tried the last 3 versions with my Ruida 644XG controller and the framing doesn’t work and I can send the job to the controller. I’m still running macOSX Mojave 10.14.6. When I try framing the laser moves in a straight line to the left and just stops there. I keep hoping the next version will solve the problem. Thanks

Can you please verify which version numbers for clarity?