Complete beginner - Alarm 9. Homing fail. Could not find limit switch


Just assembled Ortur Laser Master 2 - 20 watt. Have never used a laser machine before. Installed Lightburn trial on Macbook. Software found the laster machine, defined working area as 430x400, asked if to start from home (yes) and where is home (lower left corner). That’s all I did. However, on every restart laser now goes to the lower left corner, tried to continue somewhere and software throws Alarm 9.
All cabling looks right - I compared to multiple instruction videos.

What did I do wrong? How to fix?

Thank you!

OZ EDIT: The Ortur machine does have limit switches.

This is a copy of a reply that OZ gave another poster. I do not know if the Ortur has limit switches but it may help.

‘‘Most likely your laser does not have limit switches, but you’ve told LightBurn to home the machine when it connects. Click the ‘Devices’ button, double-click the laser in the list, then click ‘Next’ until you get to the page with the origin corner setting. Turn off ‘Auto-home on startup’ there, and that will stop the error.’’

''You will need to manually home the laser. Read here, the last paragraph, where it talks about machines without homing switches: ‘’

You could also have a look at this thread. Read all the replies as one may solve your problem

ALARM:9 : Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

That means that either the machine is moving in the wrong direction trying to find the switches, or they didn’t trigger, and both point to a wiring issue or a settings issue. The machine comes pre-configured, so unless you altered settings it’s likely wiring. Double check the wiring to the limit switches, and make sure the wires to the switches are coming out of the proper side, and the switches are mounted so the machine is making contact with them correctly.

1 Like

Thank you very much for the replies! It’s Ortur Master 2, and it only comes with one limit switch, as far as I understand. It’s installed on the front left, to the left of the control board with Ortur logo. I followed several videos on installation and my configuration is the same as in the attached image. image|690x387

The machine hits the limit switch lever when it moves all the way forward but it doesn’t seem to register, as it continues to try to move. Disabling homing on start doesn’t help, as the system is in the alert state and is not ready to burn.

I was not aware when purchasing Ortur that it’s such a hands-on process :slight_smile: Wondering if there is someone who could walk me through? Any way to call and get help? Not sure how to proceed…

@OrturTech - Can you provide assistance here?

Greetings Lara
Ortur has 2 limit switches
The Y one that you shown in your image but also a X one that is in the small PCB bhind the X gantry where the 2 white plugs connect
COuld you provide a image of this 2 white connectors behind the X gantry pelase?

Aditionally not sure if possible could you post a 20 sec video clip of your machine homing from the centr or the machine?

Hi Gil,

Thank you for the follow up reply!

Attached are the photos of all the connections. Not able to attached video here, but here is the link:

Appreciate the help!

You dont seem to have X motion at all
Do me a favor can you confirm your X belt is going over the Sproket
The image you sent is dark but seems in pre assembly the belt was missed and is not being moved by the sproket at all


That was it! So silly. That step was not in the assembly instructions, and apparently was missed due to pre-assembly.

Thank you!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.