Does Camera work on Windows 7

camera

(Brian Book) #1

Hello new user here … I want to order a Camera but I need confirmation it will work on Laptop with Windows 7 … I prefer not to update my Windows at present as everything works well right now … and I’m of the belief " if it ain’t broke … don’t fix it" :slight_smile:

Brian


(barrie williams ) #2

yes, definitely

i have mine running in a win7 64 bit Alienware.


(Rick James) #3

We had another member report they had an issue with camera on windows7 laptop that is being looked into.

Might be worth a read. Solution for the other member…updated his system to win10.


(barrie williams ) #4

i had exactly that on my win7 laptop

no picture

but when i realised the camera was an AV stream USB Video Class device i discovered we needed to install the UVC driver on win7

(it is installed by default on win8 and later)

after installing the microsoft UVC driver it worked fine on win7

“The USB Video Class (UVC) driver is a Microsoft-provided AVStream minidriver that provides driver support for USB Video Class devices.“

i was worried for half an hour, but after installing (and a full reboot) it has been faultless since.


(Rick James) #5

Thanks for that update.


(Brian Book) #6

Hello barrie and Rick … thank you for your replies and the solution … now I just have to check to make sure I’m ordering the right Camera ! :slight_smile:
Brian


(Rick James) #7

(Ray Kholodovsky) #8

I also intend to test the LB camera on Win 7, and have set a reminder for this in several days.


(Timothy Dornbrock) #9

Do you remember what exactly this driver is called. Navigating the windows driver page was a no go for me.


(barrie williams ) #10

hi timothy

I am NOT SURE, but i think it was…

https://www.theimagingsource.com/support/downloads-for-windows/device-drivers/icwdmuvccamtis/

please create a system restore point before doing it . I don’t want to be responsible for ruining your install

:slight_smile:


Camera complication?
(Eduard Rodriguez) #11

Hi Barrie, downloaded the file, but with the exe file didn’t recognize the cam. So i went to the folder /data/innos and executed the two exe files. After that i get it working. Thank You so much


(barrie williams ) #12

Thank you so much for sharing that info. I am sure it will help many others in the future.

cheers!


Lightburn camera troubleshooting
(Blake Bartlett) #13

uvc_pages.exe gets flagged by Symantec btw.


(Zoti) #14

I’m disappointed with the camera.

I finally got it running on windows 7 but it just keep crashing and dissapearing. I restarted the computer and that helped a few times but now it’s completetly gone and looks like it took my webcam that’s at the top of the screen as well.


(Blake Bartlett) #15

Sounds to me like you ought to be disappointed with your operating system and drivers, not the camera.


(Oz) #16

Which camera are you using, and with which version of LightBurn?


(Zoti) #17

I’m using the lightburn 140 degree camera with the latest version of lightburn.


(Zoti) #18

While I agree that my machine and os are not new, Lightburn works very smoothly on it. I was not expecting the camera to give me trouble.


(Oz) #19

Double check the driver installation. I only tested the camera as far back as Windows 8, but I know they are supported on 7 as well. If you haven’t run Windows Update in a while sometimes that helps as well - that’s actually a common issue, as newer devices aren’t always compatible with the older OS unless you update semi-regularly.


(Zoti) #20

I installed the drivers several times but I will try to update the system and do it again.