New DIY laser. RDC6445G. Multi-Issue. Plz Help

I just built my laser from scratch. I’m running Nema 17 steppers, which move fine.
I have some issues, however more on that in a min.
Hardware: all brand new.
-50watt CO2 laser from cloudray.com
-nema17 steppers from NOS I had from a printer build.
-RDC6445G controller
-MCWLaser CL-MYJG black model, 50w PSU
-TB6600 stand alone stepper drivers
-Meanwell 24v PSU for steppers and RDC.

Issues: X&Y axis both move fine, however I cant seem to find where to adjust the setting for max X&Y travel length, nor can I find how to set the correct steps per mm. The motors are standard 1.8degree -Nema17’s, with the drivers set to 1/32 microsteps. The belt is a regular GT2 timing belt, with 20tooth gears. So I need to set the steps per MM to 160 according the the prusaprinters.org stepper calc.
I also don’t get ANY response from the controller when an end stop switch is triggered. The motors just keep going. Only thing that happens is one of the many LED’s in the row of 15 on the RDC will light up. But that’s it…

Next issue is… With the RDC connected, I can’t test fire or even just “fire” fire the laser. If I disconnect the controller from the power supply and leave only the laser connected to the power supply and press the test fire button on the PSU itself the laser will fire. So I know the laser and the power supply are good. I have connected the door switch screw terminal (on the controller) directly to ground as I have no door. Same as the 2 water sensor positions. Both are hard wired to the closest ground location on the screw terminal block. The system is water cooled, but I don’t have a sensor…

RDC onboard diagnostics do not show a highlighted box at either water sensor or the door protection switch, but does show activity when an end stop switch is triggered. However as I already stated, when triggering an end stop switch the motors continue to run.

Can somebody please please please please please help me figure this thing out. according to the manual I found online there is also supposed to be a “Vendor” option inside the RDC menu, which isn’t there. The version is 15.01.19
Also, just to add additional information, at any given time the LED light status is show the following.
1-8 = off
9 = on
10-13 = off
14 = blinking
15 = on

If someone has the information could you also please post what each one of these lights stand for, as I was unable to locate that information in the manual…

Thanks for your time…

I’m really lost now. Did my post get merged with others?
Thanks for the info about the LED’s, I didn’t even realize it was printed on the controller…

I think I’ve got my end stops working, but still can’t adjust the steps per mm.

Also, I can’t get the laser to fire when the controller is connected to the PSU. Not even a test fire from the PSU’s test fire switch. This seems to be my biggest obstacle right now.

Ok, so looking at the other post I see where it says that I should connect to L-AN1 and not LPWM1, but idk what connection to make. I followed the wiring diagram for the CO2 laser I found in the rudia PDF. I’ll attach pics of my controller wiring, PSU pins and the diagram I followed.

Okay so ultimately I’ve been double-checking my wiring thanks to the post that someone left with pictures showing one line highlighted that said it needed to be connected in a completely different way. With double checking everything I realized I left the water protection off on my power supply itself. So after a quick jumper from water protection to ground I realized that my laser would flash on but for less than a tenth of a millisecond. Not even long enough to leave a mark on a piece of paper. so I went back to thinking maybe what he’s saying had some water to it but ultimately I double checked the installation guides I found along with the wiring diagram I posted in my last post and I had it wired correctly as per them.
I went into the lasers menu and under the laser settings inside machine settings I found a spot to change the firing type from “HIGH or LOW”… with mine being on high I ultimately switched it to low and it works. I now have a fully functional laser with XY system… it’s currently uncalibrated, but it does function and I am able to control it using the controller…
If anybody has any questions feel free to contact me I will be more than happy to help you out…

2 Likes

There is more to the PDF manual than illustrations. Reading the detail of the connector block you will find the following:

I read that, and know how to read, not only look at pictures. Lol. But, since I can’t seem to find this answer…
Is there a benefit to using the analog signal over the PWM? And just to clarify something, right under what you highlighted, in the LPWM1 section #2 shows “When The laser is a glass tube, This pin will be connected with the laser power PWM end and used to control the power of the laser.”

This is what I was trying to follow, And after finding the difference between low and high in the settings, managed to get it working.

My question for you now is, is there a benefit to using The analog setup over the PWM?
Also, can you post a link to the PDF you have for the controller, as the documents I have don’t include any of the information you highlighted and posted?
Thanks

The advantage of using the analog output over the PWM is you’re not requiring your laser PSU to translate the PWM into a 0 - 5v signal. That’s what the controller is doing. If you have a Laser PSU that accepts analog signaling, you should use it. That’s why It is recommended by Ruida.

http://www.rd-acs.com/

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.