ORTUR LASER MASTER series v1.4 Firmware Release

WINDOWS Computers ONLY - Do not Attempt on MAC/LINUX

Change Log: V1.40

Release Date: 04 January 2021

Fixes:

  • Pause/Resume issue been corrected. Laser Pause/Resume functions now work as expected;
  • Corrected False positive [Check Limits] on Pro Motherboards (RJ connector/Vertical buttons boards);

Improvements:

  • GRBL Core Upgrade from 1.1f to 1.1h;
  • Optimization of USB Driver Library. Attempt to address disconect issues/Alarm 3;
  • Fan Delay ShutDown Function. Fan will Remain on from 30 to 120 seconds, based upon the length of time and maximum power of the just finished engraving.
  • G-Shock Sensor Algorithm. New algorithm reduces the amount of false positives;

For troubleshooting or problems open ticket at https://ortur.tech/support

Repository for downloads: https://ortur.tech/latest-firmware
Full documentation included in the ZIP file

Youtube instructions
ORTUR LASER MASTER 2

ORTUR LASER MASTER

3 Likes

Thanks Gil

My LM2 doenst start after i did the firmware update -.- !??!?

Questions Knoxvill
a) windows machine?
b) did you UNZIP the files before moving the OLF_140.bin file (MANDATORY)
c) any antivirus in the background or other tool that reads files on the fly?

1 Like

Thank you very much, that was my bad, antivir was the problem.
Now it is working again. :slight_smile: :slight_smile:

1 Like

Out of curiosity, why would an Ortur LM2 firmware upgrade only be for Windows machines? what difference would the OS driving the burn software have to do with the actual laser? I have a Mac running my LM2-20W and it seems as though the firmware update may address my laser stopping issues. At this point I have purchased a shielded/ferrite beaded USB cable, grounded the machine and thought it was fixed but tried to do 2 back to back 3 hour burns and it quit 30 min into the second burn. it has improved, I used to not be able to burn anything longer than 20-30 minutes.
Is there a plan to put out a firmware upgrade compatible with Mac’s?

Roughly Speaking
Running Grbl comunications via USB serial is OS agnostic

Writing into the Firmware ROM isnt.
This was addressed with a more roburst bootloader in future boards, but the problem with MacOs is it writes into ANY connected drive a lot of hidden files. (normally .file .folder items). To perform a firmware update you need to “mount” the board flash drive, and this implys MACOS writes instantly to it this files. This confuses the bootloader while performing the firmware and corrupts it. Bricking the board

You can, if you have access to a windows machine update the firmware, but currently on MAC theres not a simple way to achieve the same
Once firmware is updated the machine is usable in all OS’s

1 Like

I understand now. I will do the firmware upgrade with my windows machine and then put the laser back on my Mac. I appreciate the rapid response and detailed answer to my question.

Just done my upgrade by following Orturs instructions to the letter but I made it a bit easier for myself by copying and pasting the relevant files into the Ortur folder that appears, then once shut down properly and rebooted, it worked flawlessly.
I want to give Ortur a Huge thanks for their top level of customer service, just as Lightburn offer.
I tried the new Dynamic Power feature too, and the speed of the fan varies in unison with the chosen output power.

I must also say that it was Only through some very prompt help and service from Ortur ages ago when I was convinced I had inadvertently messed up my Ortur M2 into the realms of Brickdom​:sunglasses::ok_hand:
For about 2 weeks after being convinced I’d tried everything, I asked Ortur and we eventually succeeded in resurrecting my Workhorse. One small issue I had, was the laser head stopped working - which was why it was useful buying an additional Head, so it was a simple case of swapping the units around, which I just did at the same time as the latest Firmware update.
I’m running Windows 10 on all machines.
Great job Ortur!

1 Like

Many Thanks!

It worked with the video instructions.
However!
I had to press the reset button within (not after) the 5 seconds (power button) to be able to connect the Ortur.

Now finally the pause button works in LB. :smile:
Only the fan has been running a little too long. (in the first test)

Viele Grüße :slight_smile: