Rotary Axis not being effected by Steps per Rotation

Good evening everyone,

I am having an issue with the rotary attachment setup on my 60W laser running a RUIDA KT332N device. Tweaking the Steps Per Rotation has no effect. I have confirmed that the settings are making it to the controller, but no settings have any effect on the amount of rotation the object makes. I have tried settings from 200 to 15,000 with absolutely no change.

Has anyone had this issue? I don’t really think it’s a Lightburn issue, but I am truly stumped here.

Using version 0.9.16 lightburn.

1 Like

Are you sure that you have ENABLED the rotary (Rotation Enabled) on the controller? In LightBurn, there is the Enable Rotary slider.

You must switch both the machine’s physical switch (which routes the stepper driver motor output to the pinned panel plug of your rotary) and enable rotary operation on the controller (so that the specific steps per rotation and diameter values are referenced).

We cannot locate a physical switch for rotary mode on the machine, we are using the rotary on the y axis. The rotary option is enabled in the controller and on the Lightburn software, but something I have noticed is that in screenshots of lightburn there is a slider in the laser control panel for “Enable Rotary”, but it is not showing up for us, even though we have enabled it in the Rotary Setup menu where we setup the values.

Is there another location to turn that on?

After searching endlessly for our controller information it appears our listing was for a Ruida controller, but instead, we ended up with a Ryxon controller. Could that be the issue? Everything else has been working fine, except for this.

You have a Ryxon controller. See here:

If you have the Ryxon, it looks like Ruida makes it. The manual for the KT332G states the following to enable the rotary (from the HMI):

Both the KT332N and KT332G support Rotary (per their published specifications)

1 Like

I don’t understand how you don’t have a physical switch on the laser machine itself (unless your machine has a really fancy rotary plug that both connects the rotary AND switches the driver wiring over to those pins simultaneously).

We are physically disconnecting the Y-Axis motor and swapping with the Rotary Motor. Is there another way to connect the rotary?

We have those settings configured, but they seem to have no effect on the output. I am truly stumped. The controller shows up in Lightburn as RDC644XG

I am loading up RDWorks to see if we have the same issue.

Thank you for all your help so far!

I have sent a square to the controller and tried setting rotary mode on the controller and doing everything on there and still having the same issue. It’s as if setting rotary mode is not doing anything. Been trying to figure out if there is another setting, or a switch that I need to enable to get it working, but with no luck.

I saw in the other thread that they adjusted the y-axis configuration to dial it in, but that seems less ideal than being able to use diameter to set this up. Really hoping to find a solution here. Even considering replacing the controller with something else.

That’s not very ideal. It sounds like the maker of your machine did not build it to include what’s normally provided for rotary use. That is, usually with Ruida controlled machine, there is a 3 position selector switch to reroute the wiring from the Y driver. For example, my switch is:

  • Position 1: Y Axis Gantry
  • Position 0: Nothing (sort of a safety - think air gap)
  • Position 2: Y Axis Rotary Panel Connector

So when I say panel Connector, it is either a 3 pin (for a three phase stepper) or 4 pin (for a Bi-Polar stepper) plug on the machine.

Your rotary would have a cable connected to it with the proper connector for this plug. With this, you would just need to position you head (use a saved position in the move tab of LightBurn), Switch Position 0, Plug in Rotary, Switch Position 2, Enable Rotary on Controller.

Now, all of this is required because although these are 4 Axis controllers (X, Y, Z, U); there are limitations on Z and U preventing laser operation and movement simultaneously.

There is a custom firmware that another machine producer uses on Ruida controllers that overcomes the limitation on U allowing it to be assigned for rotary use. Is there even the slightest chance your re-labeled Ruida controller allows for U axis rotary? You would need to check with the maker of your machine. However, if that even were the case, it would mean you’d either have to have an additional driver or similarly a switch that switches the output of the controller to a shared driver.

1 Like

Thank you for those detailed photos. That is definitely not on my machine, but I think I am going to invest the time to implement that on mine to make swapping easier.

It turns out there is an issue with the firmware on the Ryxon KT332N controller. I was using version 23.01.04 After reaching out to James in that other thread, he was able to get an updated firmware directly from the manufacturer to get to 23.01.05

I have the firmware as well now, if anyone runs into this problem and has the same controller, send over a private message and I will send it over or try and help. The process was simple, and now all the settings in lightburn work perfectly for the rotary axis I am using.

Thank you for all your help!

This should help:

To the best of my knowledge, the Ryxon KT332N controller started shipping this year, and is only used on one CO2 laser engraver model as of this writing. (Note: there appear to be multiple model numbers for the same machine, some of them of which are known as Preenex Aoshen USB-6B57, USB570-60W, USB-320S-BW, USB-6R57-US all of which are 60W, 28x20, with motorized Z-axis and Autofocus.) According to the manufacturer, the KT332N is made by Ruida and is based on the Ruida 6442. LightBurn recognizes it as a Ruida 644XG.

The Ryxon panel has extra buttons, such as Aux Air, Focus, dedicated buttons for Z axis, continuous/momentary Up and Down, and a separate Menu button, which are a nice improvement over the 6442. Oddly, they removed the Min and Max Speed buttons,

On the controller side, the KT332N is a little more stripped down, but nothing that the typical user would miss. The most noticeable is that it has connectors for only three axes (versus four on the 6442) and it does not have a connector for a second laser tube. The KT332N has an X, Y and U axis. The U-axis is used for the rotary, in comparison to the 6442 which uses the Z-axis for the rotary and the U-axis for the seldom used conveyor control. The KT332N also lacks status LEDs. Lastly, the limit switches have been combined onto a single connector. The KT332N does have ethernet, although it is not labeled.

Attached are two photos for reference.

1 Like

It seems that owners of the Mansfield rotary, and some other models, can remove the Y-axis aviation connector and plug their Mansfield rotary directly into it. This is true for some other machines using a Ruida 6442 as well. However, with the Mansfield, there is an issue where it skips the first few steps unless a dummy engraving is done beforehand. I suspect it is because the driver settings, such as amperage, differ between the stepper motors, but I haven’t been able to collect enough data to prove it out.

The first few lines being skipped is almost certainly backlash or motor slop in the rotary hardware, not a setting or voltage difference.

So far, the skipping does seem specific to the Mansfield rotary. If I am interpreting this correctly, you are saying it is an issue with the stepper motor or the belt that drives the roller wheels?

“Skipping the first few lines” is rarely what’s happening - There is play in the motor or motion system for the rotary, so when it travels to the bottom of the engraving, then reverses to work its way back up, that reversal takes a moment to re-engage the gears (or belt teeth, or whatever) so the object doesn’t rotate for the first few lines of the engraving, and they all end up on top of each other.

Try to engrave this:


If it’s completely missing the first few lines, then the result should look like this:


But it won’t. It will look like this instead:


…because the first few lines of the design are being engraved, but they’re being engraved in place, while the slack in the motion system is taken up. Many designs taper at the bottom, instead of widen, so it looks like that part is skipped. If the design is wider at the bottom, then it’s easier to see that it’s multiple lines in place.

“Skipping the first few lines” was a poor description, “multiple lines in place” as you have suggested, is accurate. The workaround right now is to place a tiny circle at low power before the design. Do you have any other suggestions?

I hope that didn’t come across as berating you or anything - it’s more to fill out the post for others who might be following, and make sure the issue is understood well.

The only things that can really be done are to put a non-cutting shape just past the design, either on the same layer or a different one, or fix it mechanically by eliminating the play in the motion.

You could also try setting the job to run from top to bottom (set the Fill angle to 180 degrees). Then, just before you start the job, jog the rotary ‘backwards’ (away from the cut) and then forwards again back to the starting point to make sure you’ve taken up the slack before starting.

1 Like