Hello fellow laser wizards

I have a tech problem. My Omtech AF2028 stopped communicating via ethernet. I replaced the cable and still having message, Data not transferred, controller busy or paused.

  • checked IP Adress and replace cable
    USB connection works fine
    my modem and hub is fine
    suggestions are seriously appreciated

The KT332N controller in my laser doesn’t have the usual Link and Activity LEDs. If the controller in your laser is a bit more upscale, it should have them and they may give you a hint.

Your upstream hub / switch should definitely have those LEDs and if it’s not happy, then I’d suspect the LAN jumper cable between the controller and the side panel jack inside the laser.

If the laser’s IP address is in the modem’s DHCP range, another device may suddenly be squatting on its address. You can check the current DHCP leases with a browser at the modem’s setup page, typically x.x.x.1 in whatever IP range it’s using.

If none of those identify the problem, then does a ping to the laser’s IP address produce any response?


Your profile says xtool D1 10 watt , so we are lost as to what model Ruida you have. Likely 6442 or 6445…

My lan led blinks… connected or not.

The console Lan:ON on the bottom right – this only indicates the hardware is connected… if there is no hardware cable between them or the router/switch is disconnected, the console will reflect the Lan:Off

I removed the Ethernet jumper cable from the machines case to the Ruida and plugged my Ethernet cable directly in the Ruida as @ednisley mentioned.

This is good I will do the same Thank you Bob

Tried the direct approach, still no ether net Computer ethernet working or I would not be send this …Laser still functions if I transfer using USB or flashdrive.
I have erased the old Ruida setting and made new …still NO ethernet
Even tried to use new ether net cable direct from computer eithernet port …still nothing
Any guess would be helpful …but for now I will try to use USB…Bob

How do you have this connected? PC → Ruida or PC → lan → Ruida?

Does the console indicate a Lan: On status?

If you don’t answer our questions, we have more trouble helping you…


Sorry for slow response. Computer- LAN - Laser (tried direct computer -laser) same results
LAN status is ON Ping test over LAN is good ( can send results)
error msg

Honestly at my wits end, I saved a test circle as a RD file transfer via Flash Drive and it came out width 36.75 Height 27.3, I also ran a usb cable same results.
does the controller have a reset or can I update controllers firmware ?

AS you can see ping packets was LOST ethernet cable 7 feet long direct from computer to laser …Bob (new cable just out of package)

Check to see if Rotary has been enabled. If so, disable it.

You almost certainly do not want to do this without a reliable backup. Resetting the firmware puts it to a blank slate, not necessarily a known good working state.

I may have missed this but not seeing this.

Can you take a photo of the panel showing your IP configuration?

Also, can you confirm the IP address and netmask of your LightBurn computer?

YES stand by , Bob

I had asked if he was wired direct or via a lan… The lost connection is the direct connect, and I wouldn’t expect it without some ip manipulation/configuration to work… Sorry about that…

If it responds to a ping, I would think it would have to be talking…


Okay, I am uploading photos requested, I miss read my ping info NO PACKETS LOST. but laser is still disconnected direct computer to laser.

my ip : IP4v

Sorry I did not rotate photos

Unless you understand networks, like how DHCP works, the pc → Ruida probably won’t work.

You would have to assign that Ethernet port an address and configure it with the pc.

It’s much easier to just plug it into your existing lan…


No worries. I can make it out.

You didn’t list your netmask but based on your IP I will assume that it’s

Is the IP of your wifi device or is that ethernet? Note that if you are connected directly from computer to ruida that you will not be able to share the same subnet between your wireless and ethernet.

I’m actually surprised it’s working at all so I’m questioning if there’s another device on the network that’s actually assigned

Try this:

  1. Set IP of Ruida to
  2. Manually configure IP of ethernet on computer to, subnet mask, gateway of

Once configured, ping What are the results?

If you get a positive result then change IP address of LightBurn device and retest.

Okay this was working on my home network before it stopped so plugging into my existing LAN is still not a successful answer…Bob

I want to thank you for your help all of you who answered, I can reconfigure the laser however I do not know how to complete your instructions.

I do want to ask from the ping that was received before my computer IS communicating with the laser ? 4 packets sent 4 packets received? And is there a was to “reset” the Controller I would restore factory settings if I could this is the first problem I have had.m

As indicated earlier I suspect another device has claimed the IP. Prove this out by disconnecting the Ruida entirely and pinging the same IP. Does it still return?

If so, that may have been the original issue for why the laser stopped working.

If you want to revert to your original topology then make sure you get a reserved IP address and use that reserved IP for your Ruida. You can typically set this up in your router.

Many routers will only serve addresses of a certain range, for example 100-254. In that case, you could manually assign a value underneath that range without fear of collision but that will be router specific.

stand by I will reset my LAN and disconnect my laser and ping …this will take a few minutes. Bob