Configuring a 3018 CNC (or other CNC-based laser) for use with LightBurn

The summary:

  • Turn on Laser Mode to get rid of the travel lines
  • You’re trying to move too fast, which is why you don’t get enough power
  • You need to zero the machine

3018’s are pre-configured for use as CNC machines, not lasers, so their settings and speeds will likely need to be changed to give you acceptable results with LightBurn.

To see the existing settings, you can type $$ into the console in LightBurn and press enter, or go to Edit > Machine Settings. Both are showing the same values, but the Machine Settings view in LightBurn is a little easier to use.

The settings you’ll most likely need to change:

$32 (laser mode) - Set this to 1 (or true / enabled). Laser Mode means that you don’t have a rotating spindle tool, we’re not pausing to wait for it to speed up / slow down when the PWM output changes, and the PWM output needs to be turned off when moving between cuts.

Laser mode ($32=1) is a ‘Variable Power’ mode which means the laser adjusts the power output from 0 at a dead stop to whatever power you request when it gets to the speed you request.


$10 (position / status reporting) - Set this to 0 (report workspace position, not absolute machine position)

$110 / $111 (max speed in X & Y) - This will likely be set to about 500, which means 500 mm per minute, or about 8.3mm / sec, and this is really slow for a laser. Unfortunately most 3018’s also have their motor stepping rates set very high (either 800 or 1600 steps per mm of travel), and an 8 bit GRBL controller will only output about 30000 steps per second, so you’re limited to a max of 37.5mm/sec (if you have 800 steps / mm) or 18.75mm/sec (if you have 1600 steps/mm). In mm/min those are 2250 mm/min and 1125 mm/min.

With GRBL, in variable power mode, if you ask the controller to go faster than it’s allowed to, it will reduce the output power to compensate. If I asked for a line at 100% power, at 50mm/sec, but the controller can only go 25mm/sec, that’s half the speed I asked for. If it ran at half the speed, but left my power at 100%, I’d get a much darker burn than I expected, so the controller cuts the power in half to match the loss of speed. If your engraving or cutting doesn’t seem to be getting the power you want, try going slower, or at least check that you are not asking the controller to go faster than it can.

More information about configuring GRBL can be found here: Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub

You’ll also need to enable Overscanning when using either Fill or Image modes in LightBurn, and may need to increase the amount quite a bit above the default if your machine has low acceleration.

Homing and workspace:
The 3018’s usually don’t have homing switches, which means that the zero point of the machine is random, in fact, wherever you have the head when you power the machine will be zero. To set the zero point properly, either power up the machine with the head at the front-left, or jog there and enter this command:

G92 X0 Y0

The above tells the controller “where you are right now is X0 Y0”.

You might also need to enter:


As this tells the controller to report position information relative to the origin set by the user, not the machine zero position. With this set, you can use the machine in ‘Absolute Coords’ mode, which is recommended. That and the other ‘Start From’ modes are described here: Coordinates & Origin - LightBurn Software Documentation

You’ll also find this useful: